SkySafari 3 vs iOS 11 (SS3 is incompatible with iOS 11)


    Unfortunately, SkySafari V3 will not be supported on iOS 11.  We can not continue to maintain V3.  We are currently developing V5 - which will be fully compatible with iOS 11.

    If you don't want to pay full price for V5 please subscribe to the SkySafari mailing list here:

    Wait 5 secs for the orange bar to appear along the bottom of the screen. We will then email you when we are running a discount promotion.

    Thank you for your continued support & understanding.


    Powered by Zendesk