New post

[IAPs]* SkySafari 7 Pro Restore Purchases Not Working (Solution: Fixed In Latest App Update)

I have Skysafari 7 Pro, 7.1.3 (1060) running on my iphone 13 Pro 256GB & Ipad Pro 256GB, and 
I can't download in-app purchases (GAIA Star Database, Apollo Lunar Missions, PGC Galaxy Database), when I press the Restore Purchases button, a percentage bar is displayed download but no advance. 
I have tried it on different wifis and with cellular data aswell, but the result is same.
I have uninstalled and reinstalled Skysafari 7 Pro, but the result is the same. I thought its because I have SkySafari 6 Pro installed and I uninstalled 6 Pro and tried, but the result is same.
The app is also getting stuck in between & suddenly crashing.
Is there a solution to this? or Did I pay for this shitty piece of software? and live with it. I tried looking for solution online but could not find answer.
I need my money back. There is no point in keeping both 6 & 7 pro side by side if this option is not working.

Regards, Bharadwaj


  • Avatar
    Keiron Smith Official comment
  • 0

    There are a number of threads on this issue.  They have been acknowledged by the development team, however, there is no update as to when this bug would be fixed.  I’m checking all the threads to see  (so far, no updates).

  • 0
    Keiron Smith

    Thank you for the report and detailed troubleshooting.

    Developers are working on the issue and will release a fix a soon as possible -- expected in the iOS 7.2 update.


  • 0
    Keiron Smith

    If you want to test the beta offering a fix for the IAPs please read carefully the following:

    Beta Testing SkySafari 7 (iOS Only) - Read This To Participate!

    Reply here when you have properly signed up.


Please sign in to leave a comment.