New post
0

Issue with slew speed - speed auto increments after slew

hi

Had an issue for while with slew speed, whereby upon initiating a goto and slewing to another target, the slew speed becomes faster but speed position slider stays in same position. Only way to get back to normal speed is to move slider down/up then back. Let me know if need any more info.

Iphone 6 IOS10

SKYFI3 (occured with skyfi1 too)

AZEQ6 and Synscan

regards

Jamie 

10 comments

  • 0
    Avatar
    Bill Tschumy

    Jamie,

    I've asked Tim who writes the scope control code to look into this.  When you say the slew speed changes, I assume you mean the speed when pressing the on-screen buttons?  Are are you referring to the speed while doing a GoTo?  The slider should only affect the buttons, not the GoTo speed.

  • 0
    Avatar
    Jamie

    hi Bill, yes the slew on screen buttons only - only this speed is affected, not the goto. The slider only affects buttons as stated, goto speed unaffected. thanks J

  • 0
    Avatar
    Bill Tschumy

    I'm still a bit confused about what you are reporting.  A GoTo will not affect the slew speed (as set by the slider) and the slider does not affect the GoTo speed (which is always full speed).  The slider only applies to slewing using the on-screen buttons.

  • 0
    Avatar
    Jamie

    hi Bill Sure, so here is a step guide to what experience - note my issue is with the manual slew speed, not goto for context / assurance.

    - Manual slew speed slider can be set to 1 of 4 settings i believe, 1 'most left' for slowest, 4 for fastest. I set to setting 2 as its slowish slew, left of centre

    - It slews away at set speed, all good so far

    - I initiate a goto command and scope slews to new target as normal 

    - I initiate a manual slew say left, whilst the slew slider stays untouched and appears on 2, the speed is very much faster now - all slew directions are either 3 or 4 type speeds, even though not touched slider at all

    - to get back to normal, i have to move slider up or down, initiate a manual slew then move slider back again to original position

    hope that makes sense - ill elaborate more if needed. Note it doesn't always happen but majority of times i use

    Jamie

     

  • 0
    Avatar
    Bill Tschumy

    OK, I understand.  We will take a look at this.

  • 0
    Avatar
    Bill Tschumy

    Jamie,

    We are unable to reproduce this and looking at the code we can't see how this is possible.  We always set the slew speed to the value of the slider with each button press.  No one else has reported this.  What firmware do you have in the hand controller?  It is possible there is something wrong there.

  • 0
    Avatar
    Jamie

    Hi I've found how to recreate and cause it- as slew buttons are at edge, if swipe in certain way the whole app slides to side slightly as if switching apps, this causes app to reinitiallise - also seems to loose local manual realignment when this happens. Same as if apps sleeps, hope this helps?

  • 0
    Avatar
    Bill Tschumy

    Well, that is an interesting observation.  However, this doesn't happen for me.  No swiping on the sides causes any sort of app switching.  The closest I see is on the right where swiping to the left will cause the slip screen "handle" to show up.  However, it doesn't actually pull the split screen panel into view unless you tap the "handle" and pull again.  I do find that if I dismiss the split view, the app does reconnect to the mount.  Perhaps this is the source of your problems.

    So do you think you've ever had any connection problems that were not related to this app switching?

  • 0
    Avatar
    Bill Tschumy

    OK, I have this fixed I believe. Your hint about the app reconnecting to the mount did the trick.  We did not reinitialize the slew speed upon reconnection so the UI setting was out of sync.

    I also think this putting the app in the background and then foreground again (which is what happen when you show/hide the slip view) may be related to your crashes.  I'll bring this up on the trouble ticket you have about it.

  • 0
    Avatar
    Jamie

    :) Superb thanks Bill appreciated!

Please sign in to leave a comment.