New post
0

Physical connection between Mac Mini and Gemini 2 scope mount.

Hello. I was trying to follow a similar issue "Connection failure Sky Safari 6 Pro to Losmandy Gemini 2 mount via IP".

The answered covered to many Apple devices and to many options to get a clear answer for my question.

I have a Mac Mini running El Capitan. I also have a Gemini 2 and want to connect the Mac Mini directly to the Gemini. I could not get a connection a all. The IP address for my Gemini 2 is 192.168.0.111, subnet 25.255.255.0,

my Mac Mini has IP 192.168.0.101 with the same subnet. I do not have any other equipment between the Mac and the Gemini. So if I set the Sky Safari port to 4030 and choose either the Gemini mount or Meade LX 200 mount, what else do I need to establish the connection? Do I need to close the Ethernet connection to the Gemini internal webpage?

Please advise me what steps to do and what data to enter.

Thank you.

Fred

 

 

 

8 comments

  • 0
    Avatar
    Bill Tschumy

    Fred,

    How are you trying to make a direct connection.  The only thing supported is our SkyWire.  Apple doesn't allow communication via an arbitrary serial cable.

    If you are trying to make a wireless connection to the Gemini, you need a Wi-Fi adapter such as our SkyFi.  You would enter the SkyFi IP address (10.0.0.1) in the Scope Setup settings and the port number (4030 for SkyFi).

  • 0
    Avatar
    Fred Goodman

    Hello Bill, Happy New Year!

    I did some testing with my Mac Mini and either the Ethernet direct connection to my Gemini 2 (G2), or the USB connection.

    It did not work wit an Ethernet connection, but it did connect with the USB cable.

    Remember, I mentioned that I have SS 5 Pro on my Mac Mini, not an IOS mobile device.

    So, I am pleased that it works with an USB connection.

    Could you or someone explain why the Ethernet connection does not work?

    It would reduce the number of cables, from my Mac Mini, to the Gemini 2 if that could work.

    Could that be a feature in a future SS OSX version?

    Those of us with a G2 use an Ethernet connection from a computer, to the G2, to interface with an internal webpage in the G2.

    That affords access to additional information and controls, not available with USB or serial to USB connections.

    Thank you again for your reply.

    Fred

     

  • 0
    Avatar
    Mario Wolczko

    Fred,

    You may find out more by asking on the Gemini-users list at groups.io.  

    Mario

  • 0
    Avatar
    Bill Tschumy

    I don't know why this doesn't work.  Unfortunately, we don't have a Gemini 2 here to test with.  Could you capture a scope log file in the case where you are using USB and in the case where you use ethernet?  Maybe that will clarify something.

    What IP address and port number are you using when talking directly over ethernet?  It *will not* be the default ones for Wi-FI.

  • 0
    Avatar
    Fred Goodman

    Hello again Bill.

    I will try to email you (or attach it to a reply post) a copy of the latest logs. I did try the Ethernet first, then another day, I successfully connected with an USB cable.

    For the Ethernet connection, I used the IP address for the Gemini 2 controller (192.168.0.111, and port 4030. I did not use the default WIFI IP address.

    Again, this is the physical connection between my MAc Mini and the Gemini controller.

     

    Fred

  • 0
    Avatar
    Bill Tschumy

    Are you sure port 4030 is correct?  That is what SkyFi listens on but it would be surprising if the Gemini listened there as well.

  • 0
    Avatar
    Fred Goodman

    Hi Bill. As I mentioned to some others I did get the Ethernet connection to work.
    The main issue turned out to be my increasingly problematic cataracts. I just needed to enter the info more carefully.
    So, the Ethernet connection between the Mac Mini and the Gemini scope controller does work.
    Now I ca do away with the USB cable altogether.

    Here is a screen shot of the Gemini controller internal network settings.


    As you can see, it uses an UDP socket of 11110 and the transparent sock of 4030 that SkySafari uses.
    In the SkySafari Telescope Control screen, I enter 192.168.0.111 as the IP address and port 4030. That works.

    Fred

  • 0
    Avatar
    Bill Tschumy

    Good to hear it is working.

Please sign in to leave a comment.