New post

Nexus DSC Connection Failure "SkySafari 6 Pro Can't Make A Wireless Network Connection To The Scope. Make Sure You've Joined Its Wi-Fi network, And Entered Its IP Address Correctly" (Needs Help From Other Nexus Users)

I have been using SkySafari 6 Pro with Nexus DSC that is installed in my home-made 18-inch Dobsonian for more than five years. SkySafari 6 Pro is installed in iPad mini2 (iOS 12.4.8) that receives Wi-Fi transmitted from Nexus DSC. Nexus DSC detects motions of Dobsonian via two encoders, i.e. installed in altitude and azimuth axes.


The system worked well until Wednesday, 23 August, 2020 UT, but connection failure occurred on Monday, 28 August UT. I rebooted iPad mini2 and confirmed settings of both SkySafari 6 Pro and Nexus DSC, but the error massage appeared again and again that reads,


Connection Failure

SkySafari 6 Pro can't make a wireless network connection to the scope. Make sure you've joined its Wi-Fi network, and entered its IP address correctly.


I confirmed that iPad mini2 joined the Wi-Fi network of Nexus DSC. Nexus DSC itself had no problem and worked well.


SkySafari 6 Pro is also installed in iPhone X (iOS 13.6.1) and I tried to connect using iPhone X, but the result was the same. I think the update of SkySafari is the cause of the issue.


  • 0
    Shigeki Murakami

    Yesterday, SkySafari 6 Pro successfully connected with Nexus DSC. I did nothing to improve the situation. Anyway, it is no problem at present.

  • 0
    Keiron Smith

    In Help > scroll to the bottom > what version of SS6 Pro are you using now?

    Please consider documenting your configuration, step-by-step, and including screenshots, so as to provide a reference for other Nexus users to read about and learn from your experience.

    Thanks for the update!

  • 0
    Shigeki Murakami

    SkySafri 6 Pro, Ver

    Nexus DSC Firmware version 1.3.7

    I hope my experience is useful for Nexus DSC users.

Please sign in to leave a comment.