New post
1

SkySafary 6 Pro Can’t Connect To Celestron WiFi After Update To iOS 14 (Answer: We Are Working On It)

Connection to Celestron WiFi worked perfectly in iOS 13. With iOS 14 SkySafari will not find the WiFi Module in Access Point Mode and loses connection in Direct Mode. In Direct Mode it reconnects but you are unable to control the telescope properly.

Edit: This happens with iOS 14.0.0 and 14.0.1

7 comments

  • 0
    Avatar
    Craig

    I’m having the same issue.  

  • 0
    Avatar
    astroroboto

    Same here … 

  • 0
    Avatar
    Keiron Smith

    Hi Adrian, Craig, Astro,

    We are aware of the issue and looking into a fix.

    Thanks for your patience.

  • 0
    Avatar
    ken reid

    Hello I have the same issue with 6 pro, thank you for looking in to this.   FYI  the same issue applies to the Celestron Sky Portal app too.

    Regards

    Ken

    ps wifi connection working ok on iOS 12.4.8 on my older devices

  • 0
    Avatar
    Keiron Smith

    When using Direct Connect mode, how long after the initial connection until the disconnection?

    Please also check:

    iOS Settings > Privacy > Local Network > SkySafari 6 Pro > Enable

    Thanks!

  • 0
    Avatar
    Adrian Bernard

    Hi Keiron,

    Thank you for working on the problem. Regarding your questions I can give you the following answers.

    On my iOS 14.0.1 devices SkySafary 6 Pro was not showing under iOS Settings > Privacy > Local Network.

    After switching to Direct Connect mode SkySafary asked for permission to use Local Network and showed up under above settings.

    It then did not disconnect anymore. Initially it disconnected every 15 seconds approximately.

    So I think Direct Connect mode is working when you get at the point where SkySafary is allowed to scan Local Network. 

    Access Point mode still does not work. I have seen that other app developers are discussing a bug regarding this issue at the moment here.

    In Access Point mode I took and gave the permission for Local Network, restarted SkySafary and the telescope mount, without any effect. IOS seems to still deny the network scan.

    Hope this helps.

    Greetings from Switzerland

    Adrian

     

  • 0
    Avatar
    Keiron Smith

    Thank you, Adrian, for your troubleshooting report!

Please sign in to leave a comment.