New post
0

SkySafari 6 Pro Crashes On MacBook Air Running OS 10.10.5 (Answer: Minimum MacOS Supported Is Now 10.12)

Error message suggests that I check with the developer to see if my MAcBook Air (OS 10.10.5) is compatible with SkySafari Pro 6. Please advise and if not please advise me on what SkySafari version can I download or can I please cancel the purchase ? The download web site states that OS 10.10 + would be compatible. None of similar posts and responses offer an answer to my issue.

1 comment

  • 0
    Avatar
    Keiron Smith

    John, 

    Please copy and paste the crash report here.

    Thanks!

Please sign in to leave a comment.