New post

SkySafari Pro can make a wireless connection to the scope, but the scope is not responding. Make sure the scope is powered on and connected correctly.

No matter what I have tried, SkySafari displays the following message:
"SkySafari Pro can make a wireless connection to the scope, but the scope is not responding. Make sure the scope is powered on and connected correctly. Also make sure you selected the correct scope type."

I have changed the equipment details in the app to match the scope that SkyFi is connected to at the time.

I am using SkySafari 6 Pro on my Pixel 4 and I also tried an older Android phone I still have laying around while troubleshooting and the message is the same. With both devices I can access the settings page of SkyFi III just fine, but SkyFi III is never able to communicate with either one of my scopes. I have attempted to connect to a CGEM II and a NexStar 8SE. I have also tried connecting through StarSense as well and the message is the same. I have tried three different USB cables and two different mounts. I even purchased an RS232 cable and I still see the same message on both scopes.

SkyFi reports that it is running version 1.3.4, and from your support page that appears to be the latest:

I have attempted connection with Time and Location both enabled and disabled because there is varying information in your support pages and forums. Still no connection to the scope.

Please forgive my frustration, but I have wasted several nights troubleshooting this. Maybe there is something I'm missing, but at this point I'd really just like to return the product and receive a refund for both SkyFi III and SkySafari 6 Pro.

RMA questions:
1) Has the unit been dropped at any time?

2) Hold the unit and move it around in a figure eight motion slowly. If you hear movement inside the unit then a component has come loose. This could be related to #1 above.
No movement.

3) Fully charge the unit, then do a full reset.

4) Power on the unit and log into its embedded web page.

5) Connect to a telescope mount and test using SkySafari. Preferably check both rs232 and usb!
I see the same error message with both cables.

6) If the firmware is older, flash with the latest firmware available.
Firmware is current.

7) Fully reset and then re-test the unit with telescope mounts.
No change, same error message.

Thanks in advance.


  • 0

    I talked with customer service today (866) 688-4175 and I must say that Simulation Curriculum's customer support is fantastic. No resolution yet, but once we understand the problem I'll post an update.

  • 0
    Keiron Smith


    Let's review the issue one mount at a time.

    #1 - NexStar 8SE

    1. Hand controller firmware version number?
    2. Does the hand controller come with an RS232 or USB port on the bottom?
    3. SS app and version number?
    4. Operating system version?
    5. Device?
    6. SkySafari > Telescope Settings > Scope Type?
    7. SkySafari > Telescope Settings > Mount Type?
    8.  SkyFi 3? Yes.
    9. Confirm SkyFi WiFi network connection via mobile device.
    10. In SkySafari > Telescope Settings > SkyFi Settings WebPage > can you access this page?
    11. Are you using StarSense on this mount?
    12. What alignment process are you using?
    13. Is the alignment confirmed in the hand controller before you try to connect with SS?
    14. Please attach a screenshot of the error message.

    Please answer these questions in your next reply.

    I'm sure we can get it all working.  Likely one small issue is holding you back.






  • 0

    I am betting that it is your serial cable. They all look alike but they are not all wired alike. It's the DB9-RJ11 adapter that is the culprit.


    I had the exact same problem and when all the dust settled it was nothing more than the cable. Just but one from Curriculum Simulation or Celestron in your case.

Please sign in to leave a comment.