New post
0

Why Is SkySafari 7 Not Compatible With My Android Device? (Answer: Android OS 10+ Required)

Both my devices that include a newer Motorola phone and a Samsung tablet have Sky Safari pro 6 installed. So I started getting the upgrade to pro 7 messages but when I follow the link it says this version is not compatible with your device. What does this mean? What version of Android software must you have?

1 comment

  • 0
    Avatar
    Pedro Braganca

    Hi Mike, you need Android 10 and higher to run SkySafari 7. Thank you.

Please sign in to leave a comment.