QuickTime for Windows Vulnerabilities

    Follow

    Due to the recent discovery of security vulnerabilities in QuickTime for Windows, and Apple’s statement that it will no longer update this software, the Department of Homeland Security has recommended that all users uninstall it immediately.

    https://www.us-cert.gov/ncas/alerts/TA16-105A

    While versions of Starry Night higher than 7.4.0 no longer require QuickTime for Windows to run, prior versions of Starry Night (including versions 3,4,5 and 6) will not operate without it.

    Users of Starry Night 7 versions lower than 7.4.0 should immediately update the latest version and uninstall QuickTime for Windows.

    Users of Starry Night versions 3, 4, 5 or 6 can upgrade to version 7, or simply leave QuickTime installed and use it at their own risk.

    https://store.simulationcurriculum.com/collections/upgrades

    Note that OS X users are unaffected by this situation in any way.

    Comments

    • Avatar
      Toad Rocket

      Search for Quicktime did not turn up this post. I submitted a comment on another Quicktime issues thread. Thank you for this info. I have SNPro6....

      What features does one loose in SNPro 7 if you do not have Quicktime installed? Is SNPro 7 fully functional without Quicktime 7.x?

       

    • Avatar
      Keiron Smith

      Hi Toad, 

      The latest version of SN7 (7.5.0) is fully functional without Quicktime.  Update SN7 and delete QT :)

      Clear skies!

    • Avatar
      davidjohnson

      Thank you

    • Avatar
      David J. Maher

      So, we are sort of compelled to update to v7?  Not that I have any reason to dislike it, but my version 6 Pro was exactly what I wanted and needed.....

    Powered by Zendesk