New post
0

Meade LX200 GPS Timed out waiting for received data

 

 

When I try to connect Starry Night Pro Plus to my 14" Meade LX200 GPS using an USB to serial cable after a couple of seconds I get the message: timed out waiting for received data

I have the latest LX200 GPS Ascom driver installed. My Starry Night program is up to date.

I can connect to the scope using Meade Autostar Updater.

I carried out "Garbage collection" on the Autostar Handbox.

I can operate the scope using "Cartes du Ciel".

My OS is Win 10 Pro 64 bit

I unchecked the "Set time" box in the SN telescope connect window

When I unplug the telescope I get the message: Nothing seems to be connected to this port.

I have also tried a different computer with Windows 7 Professional 64 bit installed, the failure stays the same.

May be someone can help me, regards from Germany.

 

Rainer

11 comments

  • 0
    Avatar
    Keiron Smith

    Hi Rainer, 

    Please attach 2 screenshots here - one screenshot for each of the error messages that you are receiving.

    Thanks!

  • 0
    Avatar
    Keiron Smith

    From here 

    http://www.ascom-standards.org/FAQs/Index.htm

    The very bottom...

    How do I enable and disable serial tracing?Most drivers use the ASCOM "Helper" component to do serial port I/O. 

    For those drivers that do, you can capture a trace of the serial traffic to and from the device by using serial tracing. Beginning with ASCOM Platform 5.5, the Chooser has a Trace menu. Use this to set the location of the serial trace log and to turn tracing on and off.

    Do you think you can get a trace log?  It may shine a light on what is happening.

    Thanks!

  • 0
    Avatar
    Keiron Smith
  • 0
    Avatar
    Thor

  • 0
    Avatar
    Thor

    Here is a screenshot of that Timed out window. Where do I find this Trace Menu? I cannot find it in the LX200 GPS / R menu. Or do I have to run a separate program such as the ASCOM Diagnostics?

    Regards

    Rainer

  • 0
    Avatar
    Thor

    Last night I tried another Autostar 2 Handbox but the result was the same. I`d also installed and tested the

    Meade Universal Driver Project (June 2014)

    since it says it would support earlyer LX200 GPS models. This time I could connect the scope at first try. I could slew the scope to the first object and then the connection was disrupted. When I tryed to slew to another object the "disconnect" button changed to "connect" but was greyed out and didn`t react any more. I had to restart Starry Nights, could connect to the scopt but after slewing to the first object the connection was interrupted again.

    Regards

    Rainer

  • 0
    Avatar
    Thor

    Here is a screenshot of what I get when the scope is disconnected or the USB cable unplugged. Is says "The connectinn COM 3 is not available". So there must be some sort of link to the telescope.

    Regards

    Rainer

  • 0
    Avatar
    Thor

  • 0
    Avatar
    Keiron Smith

    Hi Rainer, 

    Please test with another USB cable - just in case.  I know it not likely, but let us cover that base.

    There should be a serial log file available, have a look at this:

    Does that help?

     

  • 0
    Avatar
    Thor

    Hi Keiron,

     

    the problem was solved today. The guys from the ASCOM forum put me in the right direction. After trying several things over the last couple of weeks I finally found the solution. There seems to be an issue with the german autostar 2 software. Today I installed the english version and now the scope connects to Starry Night without any problems. Thank you fou your support and ideas.

    At the end of the day it was the germans. Again...   ;-)

     

    Regards

    Rainer

  • 0
    Avatar
    Keiron Smith

    An excellent result, Rainer!  I had no idea there was an issue with the German version of Meade Autostar 2 software.  This is an amazing breakthrough!

    Thanks for sleuthing out a solution.  Thanks to the Ascom forum too! 

     

     

Please sign in to leave a comment.