New post
0

Minimum requirements for an Android tablet for Sky Safari

I am contemplating purchasing one or more Android tablets for use with my telescopes and Sky Safari Pro. The intent is to control the telescopes through Bluetooth, or possibly wi-fi (which I have heard some newer Android versions allow now). There are a lot of tablets out there, quite a number very reasonably priced. Is there a minimum and/or recommended system specifications for such an Android tablet?

Thank you!

Tim Stoffel

4 comments

  • 0
    Avatar
    Bill Tschumy

    Pretty much any modern tablet will suffice.  I would avoid the no-name brands.  If you want to use the compass feature, make sure whatever you get has a digital compass.

  • 0
    Avatar
    Keiron Smith

    Hi Tim,

    With Android tablets you get what you pay for.  I suggest picking up one of the better brand-name tablets - ensure you're getting the best available at this time.

    Double check that it comes with a compass if that is important to you as well.  

    Others in our community can offer specific recommendations.

  • 0
    Avatar
    Chris Brandt

    I'm curious if there will be a minimum Android version for SS6 Pro?  Is there currently a minimum for SS5 Pro?  Thanks!

  • 0
    Avatar
    Bill Tschumy

    SS5 should run on Android 4 or higher.  We have not decided to what the requirements for SS6 will be.  It would be nice to make it Android 5+ but according to this chart, that would cut out almost 25% of our current market.

Please sign in to leave a comment.