New post
0

connecting SkyFi-USB to iPhone hotspot

I have a SkyFi-USB, currently connecting to an iOptron Cube Pro. I have successfully connected first through the ad hoc network, then through my local wan.

Is there a way to connect directly to an iPhone hotspot? I'm on an iPhone 7, iOS 10.3.1. I'm on Verizon and have the hotspot turned on.

I tried entering the SSID and password manually but it wouldn't connect. I'd like to have this capability for the field where I'll only have cell connections. I know I could use the

ad hoc but that creates other problems trying to connect to the internet.

6 comments

  • 0
    Avatar
    Bill Tschumy

    I have never tried this.  I don't see why it wouldn't work though.  I will give this a try on Monday or Tuesday and se if it works for me.

  • 0
    Avatar
    wtxnitz

    I think my problem is telling SkyFi the IP address through the iPhone. Or the iPhone is not allowing access and I don't know if/how to have it do so.

  • 0
    Avatar
    Bill Tschumy

    OK, I was able to get this to work, but there were some mysteries I don't fully understand.

    First, I realized I needed to give my iPhone a name without spaces in it.  Previously, it was called “Bill’s iPhone 6s”.  This works fine when connecting to the hot spot from my other iOS devices.  But I’ve noticed I could never join the hotspot from a Mac (it wouldn’t appear in the network list).  After some Googling, I found that you cannot have spaces in the name (I guess SSIDs can’t have spaces).  After changing it to “Bill_iPhone_6s” I saw the hotspot from my Mac and was able to join it.

    I then tried from the SkyFi.  I chose ”Connect To Network” from the Wireless setup page.  It did find "Bill_iPhone_6s” when scanning for networks.  I chose it and enter the password and hit “Save”.  It did of seem to join the network.  What was strange is that, I still have “SimCur SkyFi” in the list of networks I could see from my Mac.  Generally that would go away if it successfully joined another network.  It looks like I can talk to the SkyFi through 10.0.0.1 and 172.20.10.9 (which is the address assigned by the iPhone hotspot.  Weird.

    I was able to control a scope this way.  I did have to manually specify the 172.20.10.9 IP address (and port 4030).  The Auto-Detect cannot find it on the personal hotspot for some reason.

    I have sent an email to the person that wrote the SkyFi 3 firmware to see if he understands what is going on.  I don'ts how the SkyFi can be available at the 2 IP addresses.

    Anyway, except for the Auto-Detect, this does seem to work.

     

  • 0
    Avatar
    wtxnitz

    It works! Sweet.

    A few minor differences. I've never had a problem connecting to the hotspot from my Mac with spaces in the SSID.  BUT it did make a difference on the SkyFi. When in the ad hoc mode, I could see it in the list ( I could not before) and was able to select it and set the password.

    Once I did that, I could connect through SkySafari, either Mac or iOS. I think this is how I did it. I'll have to play some to determine the correct path.

    On the Mac on hotspot, I could use auto detect. That got me the IP address on the hotspot. I then put that in the iOS and voila! connected.

    From either I can control the scope. I do not see the SkyFi on 10.0.01 while on hotspot. btw my phone assigned 172.20.10.6. auto assigned I  assume.

    Thanks. Now I have a viable option for the field.

    Question, Is it a problem to have two devices connected at once? I have always assumed it was a nono and disconnect before changing devices.

  • 0
    Avatar
    Bill Tschumy

    Glad it is working.

    I certainly have had it work with 2 devices connected to the SkyFi 3 as long as only one is actively communicating with it.  However, that is not really a use case we have designed it for so it is possible there could be subtle problems.  Better off to only have one device connected to the SkyFi 3 at once.

  • 0
    Avatar
    wtxnitz

    Ok Thanks!

Please sign in to leave a comment.