New post


I have a MEADE ETX-60 telescope that is connected correctly to a SKYBT adapter. EASY ALIGnment was performed first on the ETX-60AT and pairing of SKYBT successful to my ANDROID turbo2. Trying to connect within SKYSAFARI 5 PLUS and receive error message that SKYBT has established connection but cannot control scope. HERE IS THE LOG FILE:
Sent ASCII at 2017/07/26 22:23:10 with error 0:
Received ASCII at 2017/07/26 22:23:13 with error -13:
Sent ASCII at 2017/07/26 22:23:13 with error 0:
Received ASCII at 2017/07/26 22:23:16 with error -13:
Sent ASCII at 2017/07/26 22:23:16 with error 0:
Sent ASCII at 2017/07/26 22:23:16 with error 0:
Received ASCII at 2017/07/26 22:23:19 with error -13:

I have a #497 autostar controller -meade....


And whats the story with the DIP switches on the SKYBT device?


  • 0
    Tim Campbell

    You may want to post this question in the SkyBT section located here:

    I'm not sure what error -13 is... that may be a time-out error (meaning scope didn't respond).  If there's a communications settings mis-match then it may have responded with gibberish that SkySafari couldn't understand.

    As for the DIP switches... the SkyBT is based on a Roving Networks FireFly BT (this is actually the device I own.  I purchased it shortly before it was available through Simulation Curriculum.)  

    Some background:  When I was searching for a BT adapter for my own scope, I was finding that most defaulted to a high baud rate and could only be changed by sending serial commands.  That's great if I'm using a terminal program, but when a device is under control of software I didn't write, I have no way of injecting the command that changes the baud rate.  This meant most of those devices couldn't be used for my astronomy software.  One of the advantages of this device is that it actually has flash memory.  It can be configured and it will "remember" those settings the next time it is used.  That makes the device appear to be "transparent" to the software... it just uses it as a serial port without having to worry about configuring the communication settings each time (it is "as if" you had a hard-wired serial cable between the two devices that are communicating.)

    I mention this because Simulation Curriculum may have pre-configured the device to use appropriate settings compatible with most mounts (and in my experience, most mounts used a baud rate of 9600... at least everything I've encountered to date.)

    Switch 1:  This is used to perform a "factory reset" ... except that'll be the factory reset according to the Roving Networks defaults ... which defaults to a baud rate of 115kbps (among other settings).  That's too fast for most mounts.  I would NOT use this switch to perform a reset unless instructed to do so.

    Switch 2:  This is used to enable auto-discovery mode.  Auto-discovery mode is only used when the device is used with other SkyBT (Roving Networks Firefly BT adapters).  You will not likely use this mode because you are most likely not going to have more than one of these adapters.

    Switch 3:  This is another switch you won't use.  It sets the device to "master" mode.  But this is only used when you are using multiple BT adapters.  You are using this device as a bluetooth "slave" with the master either being your phone or your laptop computer.

    Switch 4:  You might use this switch.... if in the OFF position, the device either uses (a) 115 kbps or (b) whatever software-configured baud rate it's been set to use.  If this switch is in the ON position, the device uses 9600 bps and ignores any baud rate set via software.

    I do not know if Simulation Curriculum reconfigures the devices stored settings to set it to 9600 bps... or if they just toggle this switch to the ON position (which would do exactly the same thing.)  (I own the Roving Networks version of this adapter.)


  • 0
    Bill Tschumy

    Tim gave a good description.  The DIP switches should be left alone for the operation of controlling a scope.  All should be slid towards the red on/off button.

    SkySafari knows what baud rate; parity; # stop bits, etc the mounts need and we automatically program the SkyBT to the required settings.

    The -13 error is indeed timeout.  The mount has not responded to out command in the expected amount of time.  This problem is generally caused by:

    1. Failure to star align the cope before trying to connect (which I see you did).

    2. Choosing the wrong scope type in the SkySafari settings.

    3. Some sort of cabling problem.  You must be sure to use a AutoStar serial cable.  A random serial cable will not work. 

  • 0
    Jerome Womack

    I had the same problem with my LX90. I solved the problem by selecting other telescopes in SkySafari, when I finally tried on of the LXD's it finally connected and I returned it to LX90, and I haven't had trouble since.

Please sign in to leave a comment.