New post

Serial port connection to iOptron AZ Mount Pro

I can connect from SkySafari 6 Pro to my iOptron AZ Mount Pro using Wifi. But I would like to connect using a serial cable. I have not been able to get this to work. The message I get is

Connection Failure

The scope is not responding.  Make sure it is connected and powered on.  Also check that your scope type is correct.

I can connect using a Windows laptop, but I would like to do it from my Mac. I want to use the cable so that I can still be on the internet while I am using the mount.

I have a USB C to RS232 cable on the Mac. I have installed the recommended driver for the cable. I use the cable that came with the mount to connect to it. I have tried plugging in to the hand controller and the mount, and I have tried using a MacBook Pro with Apple silicon, and using an iMac with Intel chip.

I used a program called CoolTerm (an RS232 debugger) to test the underlying connection, and that seems fine. But I cannot get any response from the mount.



Please sign in to leave a comment.