New post

Astrophysics GTO will not connect to designated com port & Maxim DL

Originally from ticket #7727.

I have an Astrophysics GTO Mount PIer Mounted. All Drivers etc. are less than one month old. Friday I had trouble connecting SNP but found the cure in your support section which involved starting SNP as administrator. I was able to connect to the teslescope (mount) starting SNP as administrator, also connected mount to the ASCOM Mount controller and to verify everything working slew to a star at the zenith. Connected to camera a Starlight Express SXVR started the cooler etc. an all worked. I then shut down camera, parked mount to park position 1. Disconnected telescope in SNP and shut the obervatory room.

Today I can connect SNP or I can connect the ASCOM GTO900 Controller to the mount but it will not connect both. Whichever one connects first gets doesn't seem to allow the other to connect to the comport. The com port is verifiable as COM 6 in the GTO ASCOM based controller and it verifiys that there is a connection Q something as I recall. SNP errors "not connected to mount" I tried the first 13 com ports with no success but the device manager shows the keyspan USB Serial Adapter installed at com 6 so I thing it is futile to check further.

Surely more than one device can share a com port otherwise the mount would need several connections and it seems that too would be problematic (This mount actually does have two RS232 Connections).

Confirm the checklist:

1. Latest Ascom platform

2. Latest driver

3. Latest firmware for paddle.

4. Latest driver for USB to Serial cable.


I can confirm I did the check list and all
is fine. Since I posted the request I think I managed to figure it all
out, partly on my own and partly with the help of Howard (The Tech) at Astro
Physics. First, as far as I can tell, there is no need to connect to the
telescope (the mount) in Maxim DL, however you can do it. You
just can’t go into the ASCOM AP V2 Driver setup-up (Properties) when it
is connected elsewhere (such as in SNP). It will not allow changes
when it is being used elsewhere and basically when you try it locks up the
works. You just simply hit connect and you connect. Strangely
enough I never tried that. I’m so used to going into properties and
verifying the setup.

The point is though, that once you have
SNP running, at least for what I’m doing, there is no need to connect Maxim
DL to the mount. (I’m told there are situations where that is
indeed necessary…I just haven’t gotten to one yet). SNP connects
fine and works fine.


Please sign in to leave a comment.