New post

Connection problems between Meade LX600ACF and LX200GPS scopes and SkyFi


Oct 11, 17:19 EDT

This is a follow-up to your previous request #33768 "SkyFi Testing"

Hi Bill, 

I have worked for more than a year trying to make this work reliably,  I would like to bring you up to date on work arounds that I have been using to getting a connection to my scopes. The scopes that I use regularly are Meade's LX200 GPS 12in and a near new LX600 ACF 12in. When we last communicated, you had come to the conclusion that I was having voltage problems. I bought Meade's big 110VAC brick but with no luck so I no longer think it's the voltage. I also bought 2 new SkiFi's from you that that I keep fully charged. NONE OF THIS HAS HELPED.

Both have the same reproducible symptoms.

Now I’m using iOS SkySafari 6 pro (started with version 4) and Stella (Meade would only talk to me if I used their Stella app).

Here is what I can reproduce.
After I have carefully completed the  setup, startup, alignment and connections between my iPad and SkiFi, this is what happens:  

I have connected via WiFi between my iPad and SkiFi through my settings and checked by typing in to confirm SkyFi status.  
First try in connecting almost always brings on the "Can connect to SkiFi but the scope is not responding" error.  Yes, I do have the scope type correct.


At the point the scope is not responding to SkySafari or Stella.  But the scopes work fine with the hand controller and all other ways other than the RS232 port. 

What I have found that almost always lets me make a connection after this error:

After the error message, I can usually get it to work by closing and restarting the app (iOS on iPad or iPhone)or sometimes use Meade's hand controller to goto an object first. The restart of the app now allows the scope to connect by touching the connect button and to work as expected with SkySafari, connecting for the rest of night. But on occasion this second connection the scopes will go into what I call RUNAWAY mode. Here are the symptoms when I know when SkySafari is in RUNAWAY mode. If I chose an object from SkySafari  to view I then try to select the goto button in scope window and it will not recognize my touch and goto will not turn to stop. It is now in RUNAWAY mode. The runaway now happens if I try to use the arrow keys on the app. When the runaway happens the scope starts to slew but does not stop when I release the button. I am only able to stop it by grabbing the hand controller and touching the directional keys or turning the scope OFF. NOTE I had to buy a new DEC motor after one burned out on one of these RUNAWAYS on the LX600.


Things I think we can now rule out.

1. Voltage is OK. I now use either Meade's LXPS17 power supply or 110vAC 12DC, 2500maA transformer
2. I own 3 SkyFi's Firmware v1.3.4 SkyFis are not the issue, at least not after a connection has been made and established, they works normal.  They all show the same problem.  
3. Cables. At first they seemed to be the problem but if it is the problem, I have at least 6 cable that are bad.
4. The Scopes. I talked to Meade about this. Their reply was “The RS 232 is a simple communication link and that the chances for ports on both scopes RS232s being defective and the scopes working fine with the hand controller just did not make sense”

Now I’m using iOS SkySafari 6 pro and Stella (Meade would only talk to me if I used Stella app).

I have been living with this for a while. I would like to work with someone to find the problem. 
It seems to me that it is a handshake connection problem.

I hope to hear from you.



I added this later thinking it might give some insight.


Ok, What do you think of this.


Trying everything I could think of.  I have found that after I have both scopes working I can switch between scopes by simply  switching skyfi’s between scopes from the iOS settings. I found there is no reason to disconnect SkySafari app to change scopes SSID. I can run both scopes. (one at time but not having to log out of one  skyfi to change to the other scopes skyfi.) SkySafari  will disconnect  and reconnect over and over without a problems. NO connection problems doing this.  Cool at star parties.


So then this happened 


I was getting ready for public night star party at the Tulsa astronomy club. Big active club see website. 


I was setting up both scopes. I had started SkyFi 1 and connectied it to my iPAD.  But trying to connect to SkySafari  to Scope 1 I got the connection error so i restarted SkySafari app and connection was made for the rest of the night. Now i started Scope 2 and connected to scope 2 by to skyfi  But trying to connect to SkySafari here comes connection error. So I wondered what would happed if took the skyfi 1 that was working on scope 1 and try it on scope 2. Without turning it off I moved skyfi from scope 1 to scope 2. It gave me the same connection error. I then tried Skyfi 2 on Scope 1 it  connected to SkySafari with no problem.  Both Skyfi’s worked on scope 1 after that.  I then I moved skyfi 2 back to scope 2 and got connection error.  Now not wanting to restart the app I instead used  scope 2’s scopes hand controller to goto a object that was up at the time. NOW I Skyfi 1 and 2 both work on  scope 2.  I Had  no more problems for the rest of the night.


Please sign in to leave a comment.