New post
3

[Bug]* SkySafari 6 Pro on Android + Celestron StarSense Plate Solve Fail

My setup is Celestron Advanced VX mount, StarSense camera, Celestron Wi-Fi.
The last time I was using my scope was on July 13/2019 (two weeks ago) and all was working just fine.
Then last Saturday (July 27/2019) i was no longer to successfully align my scope connecting to SkySafari
6 Pro or SkySafari 6 Plus. Connections to scope no problem, StarSense working solving Plate number one
but any subsequent attempt to solve next plat ended up with error, not able to solving plate. Tried
numerous times no success. Happened with both SkySafari 6 Pro and Plus.
Run aligning procedure with StarSense hand control successfully. So, there is no problem with StarSense
camera.
then run aligning procedure with my old SkySafari 5 Pro again successfully. So, there is no any
connection problem.
I run all these procedures (failed and successful) from my cell (Android) and from my tablet with the
same results. So, there is no hardware problem.
I uninstalled and reinstalled SkySafari, no fix. I set SkySafari to defaults, no fix.
So, what happened between July 13 and July 27?
There was not any hardware change. Only change I can think about was purchasing and installing Apollo 11
Mission in bought SkySafari 6 Pro and Plus. My old SkySafari 5 didn’t have this option so it reminds
unaffected and work.
So, my conclusion is the culprit is Apollo 11 Mission or any other possible update to SkySafari.
Would be nice if somebody read this and consider fixing this issue.
After all, at this point SkySafari is useless to me and quite expensive lemon.

141 comments

  • 0
    Avatar
    Woody

    Daniel,

    Whoa!  Now I'm really confused.  This Beta version is for SkyPortal -- not SkySafari.  I thought SkyPortal worked.  It did the last time I tried it.  And I thought you needed to make changes/fixes to the SS firmware before SkySafari would work.  But I don't see a new Beta SS version on the Team Celestron site.  The last SS Beta firmware I see is the July 29 version -- which I installed back then.

    What am I missing?

    Woody

  • 0
    Avatar
    james schultz

    Is is the link just for android could not get it to load on iPad Pro just noticed this thread was for android just installed it on an android will test once I can see the sky

  • 0
    Avatar
    Daniel Goodwin

    Thanks James!

    Woody,

    This portion of the SkyPortal/SkySafari code are identical. StarSense on SkyPortal/SkySafari broke last summer. The last update to SkyPortal was released to public before that, whereas SkySafari has had several updates since that time. Hence why SkyPortal works and SkySafari does not. So if you download the SkyPortal beta and verify that everything is good, then Simulation Curriculum can release an update to SkySafari.

    Also, the StarSense hand-controller firmware updates have no effect on SkyPortal/SkySafari. And we have not released an update to StarSense camera code in seven years. The only firmware update that affected this StarSense+SkySafari issue was a bug in the Evolution firmware. So for Evolution users, make sure you have the latest beta firmware. Hopefully that clears things up.

    -Daniel

  • 0
    Avatar
    james schultz

    Daniel,

     

    is there a bata for IOS,  I have a evolution with wedge and I had no issues with plate solving, I just upgraded to the CGX and that is when my plate solving issues started.  I have down loaded the android version and will test it as soon as I can see the sky again

  • 0
    Avatar
    Daniel Goodwin

    Hi James,

    It is a bit of a pain to create a public beta on iOS. But this portion of the code is the same between Android and iOS, so if it works on Android then it will work on iOS.

    Look forward to hearing your results on the Android beta. Make sure it is version 3.3.0.1. Thank,

    -Daniel

  • 0
    Avatar
    Woody

    Thanks for the explanation Daniel,

    I still can't test the Android SkyPortal Beta version until the weather clears up.  And that could be a week.  But as soon as it does clear, I'll test it -- unless you've already released it by then. 

    Woody

  • 0
    Avatar
    james schultz

    Daniel,  when I attempt to connect to the CGX I get the message "connection failure celestron sky portal can connect to the scope but the scope is not responding...".

    I can connect to the evolution and start an alignment (all clouds). Having never  having the non bata for android  I do no know if this is a bug in the update or my cheap tablet.  The IPAD with with non bata version still connects so I have ruled out issues with the mount. 

    It would be good to have someone else test it with  CGX too.

     

    Jim

  • 0
    Avatar
    Daniel Goodwin

    Hi Jim, I will pass that info over to my colleague. As you continue your testing, please post your results on Celestron's beta testing forum 'TeamCelestron'. That way it keeps this forum from getting out of hand and Celestron can better track beta tester responses. The link to the specific forum for this beta is posted below. If you are not already a member of TeamCelestron, please sign up to become a beta tester. Thanks!

    https://teamcelestron.com/viewtopic.php?f=71&t=1612

  • 0
    Avatar
    james schultz

    Update the link sent us to an old beta version they just posted the new version today tso if you down loaded make sure you have SkyPortal Beta version 3.3.0.1.  The 3.2 version that I down loaded last night had a lot of bugs in it.  3.3.0.1 works with the CGX.

  • 0
    Avatar
    Fanaticws

    Hi everyone,

    The last night we got a clear sky so I went for it. My setup: Celestron Advanced VX, Celestron StarSence, Celestron SkyPortal WiFi and Samsung Galaxy S10+ running SkySafari 6 Pro.

    Connecting no problem, aligning first plate attempt fail but consequent plates were solved and aligning was successful. Adding reference star fail every time, calibrating scope with camera fail every time.

    So some problems are there, hopefully update will fix it. Soon maybe too?

    Cheers  

  • 0
    Avatar
    Garry Bluhm

    Hi Fanaticws,

    Have you tested the SkyPortal Beta v3.3.0.1?

    With my CGE mount using the Beta still have numerous plate solve failures but ultimately manages to align.

    There doesn’t seem be very much feedback yet on the testing of the Beta hopefully some clear skies will help.

    As of right now forecast is looking promising for this Saturday to do some more testing, but here in cloudy Michigan

    that can change in an instant.

    Garry

  • 0
    Avatar
    Fanaticws

    No I didn't try SkyPortal. I had one rare beautiful clear sky and I was happy scope was aligned. Didn't want to waste more of precious time. 🙂

  • 0
    Avatar
    Rob Cittadini

    Just wondering if anything ever came of this? I found an old Samsung Galaxy Tab S2 that had the Pro app installed and hadn't been updated since late 2019 or so. I disabled auto-updates, connected it to the Evolution 9.25 mount via built-in WiFi and it worked perfectly! Alignments never fail, no plate solve issues, tracking is flawless, etc. Since then I've been using that old Galaxy Tab S2 until there's a fix in place for the app on the Tab S4. Note that I haven't updated the mount firmware or star sense firmware since the scope was purchased in winter 2019.

  • 0
    Avatar
    Daniel Goodwin

    Hi Rob and Everyone else,

    I just wanted to notify everyone that SkyPortal has a new update released today which contains one last major fix to the StarSense code. I have tested this out thoroughly myself and was able to align tens of times without a single failed alignment or a single failed plate solve. SkySafari should be receiving an update soon as well.

    And Rob, please update your evolution firmware to the latest available version as bugs were found and fixed related to StarSense and SkyPortal/SkySafari.

    -Daniel

  • 0
    Avatar
    Garry Bluhm

    Daniel,

    Thanks for the heads up.

    FYI,

    Updates for iOS are now available for download/install :SkySafari6Pro v6.7.0.1 & SkyPortal 3.3.0.5

    Just need some clear skies to test .

  • 0
    Avatar
    Woody

    Daniel,

    Thanks for the work and updates.  I see a new version of SkyPortal for Android, but not SkySafari-6 Pro for Android yet.  I now have clear skies, but my Evo is all loaded up in my RV for a long trip -- and the RV is an hour's drive away.  This is worth the drive to get it back and test it before we leave.  But I think I'll wait to hear from some of the others here first.  I've been fooled and disappointed with this before.

  • 0
    Avatar
    Garry Bluhm

    Tested on deck at home with light polluted & bright moon washed out sky. First run on my iPadPro with SkySafari6Pro went swift & perfect w/o any errors. No calibration problems encountered. Performed several more StarSense Auto Aligns with same results. Goto was accurate also. Used Celestron CGE mount w/SkyPortal WiFi gen3, iPadPro iOS 13.4.1, SkySafari6Pro v6.7.0.1

    Next decided to test SkySafari6Plus v6.7.0.8 on 2 older android phones (Android4.4.4&7.0). All went perfect. That’s a first. Might actually use the Moto Droid Maxx now because I like the true balcks of it’s OLED display.

    Tested my iPhone7+ with SS6Pro and it went perfect too.

    Many thanks for all involved from Simulation Curriculum, Keiron & Celestron, Daniel.

    To quote Woody “YIPPEE!”

    Garry

  • 0
    Avatar
    Ronald Roper

    I Downloaded and installed the just released versions of Skyportal and Skysafari 6 pro yesterday and tested both last night on my Samsung A70 with Android 9. Both apps auto aligned my Evo 8 with Starsense first time and without errors. Goto was also very accurate all over the sky here in Melbourne Australia. Very pleased and thanks for the perseverance of the teams involved.

    My only remaining issue is frequent screen freezes or lockups in both products that I cannot identify the cause. Tried both direct connect and access point with similar results. I expect it might be Wifi interference from nearby home networks from the neighbors. I am not using USB 2 rather than USB 3 to connect to my camera as I suspect the USB 3 interferes with the WiFi signal.

    Thanks again for the updates.

    Ron

  • 0
    Avatar
    Hayden Peter Ferdig

    I have taken my scope out twice since the updates. I have the Celestron CGEM II mount, with my Edge8 HD, and StarSense. It aligned successfully on both nights with the StarSense and SkySafari 6 Pro on my android LG G8 phone. Using direct WI-FI connection to the SkyPortal Module from my phone. I am so glad it finally works! It is so nice being able to control my scope with SkySafari rather than the hand controller. 

    A few tips that have helped me with my setup:

    I set the screen time-out on my phone to as long as possible (10 minutes). If you have an android phone, and you enable Developer Options on your phone, you can enable a setting where your phone does not go to sleep while it's plugged into the charger. This would only be helpful if you keep your phone plugged into a portable battery pack while using it. It keeps the screen from timing out. If my phone is on battery, and it does go to sleep and lose connection with the scope, once I go back into SkySafari, it reconnects with my scope almost immediately and luckily it does not ever lose alignment, I can pickup right where I left off. I also disable Mobile Data on my phone because I do NOT like to get texts, phone calls, facebook alerts, etc while using my scope. I only keep the WIFI enabled, and I turn mobile data back on after I am done observing. I also turn off bluetooth since I don't need it. This is VERY easy to do on most android phones, if it's not immediately apparent in your settings, google it. Another thing I find useful, is putting the SkySafari app on the home screen on your phone, so if the screen does go to sleep, the icon to restart is right there.

    THANK YOU Daniel, Keiron, and whoever else worked to fix this issue, it was well worth the wait!!! 

  • 0
    Avatar
    Fanaticws

    Hayden,

    Try to check mark "Prevent Sleep" in "Appearance and Behavior" in SkySafari 6 Pro settings. It works for me.

  • 0
    Avatar
    Woody

    Yeah, that's what I was going to recommend too, "Prevent Sleep."  Then your phone (or tablet) stays on al as long as you have SkySafari running.  Well, until your batteries run down.

Please sign in to leave a comment.