New post

Sky Safari Pro 6.4.0 Observations Database Problems

I have repeatedly (4 or 5 times this year, at least) had my observations list become suddenly unopenable. When this occurs, the symptoms are as follows: I select Observe->Observations from the menu and the observations tab does not open. If I then try to open any other tab, such as "Time", "Location", "Observinglist', etc, nothing happens. If a tab is already open (such as info on an object), when this occurs, it remains stuck open. The only fix is to quit the application. Then I can open all tabs such as "Observing lists", "Time", etc, but if I try to open "Observations" again, they won't open, and the current tab state gets stuck again and I have to restart the application. 

To fix this, I can sometimes back into individual observations by getting info on the object and then getting observations for that object and then observation database starts working again and I can open observations. Other times, this doesn't work and I have to keep deleting various Sky Safari related files from my the Library folder until the "Observations" tab becomes openable. SkySafari then takes a few minutes to repopulate the local Observations database from LiveSky.  

I have downloaded the observation list from LiveSky and can see that I have an observations database containing over 1600 entries. I can find no pattern in the actions that lead up to this problem. No computer crashes or program crashes seem to have occurred before this condition suddenly occurs. It can randomly occur right in the middle of a observing session as I am adding observations, or much later when I simply want to view an observation and haven't been recently adding, deleting or editing Observations in any way. 

Very frustrated. I am using Mac OS X High Sierra 10.13.6 on a MacBook Pro with 8gb of RAM.


1 comment

  • 0

    I just opened SkySafari on OS X this morning and tried opening "Sessions" again this morning, and it worked fine. I didn't do anything to try to fix it since I last tried it yesterday. Is there some sort of communication problem with LiveSky that can trigger this issue?


Please sign in to leave a comment.