New post
0

[Installer]* Why Can't I Download In-App Purchases On iPad/iPhone? (Is Anyone Else Experiencing This?)

I have purchased Apollo Lunar Mission and PRC Extension DB. Despite repeated attempts (and clicking on "restore Purchase"; these apps will not load. I have rebooted iPad and apps do not load

10 comments

  • Avatar
    Keiron Smith Official comment
  • 0
    Avatar
    Keiron Smith

    Hi Ted, 

    Is this still an issue?  If so, please reinstall SkySafari.

    Thanks!

  • 0
    Avatar
    Ted Brauch

    This is still an issue. I have reinstalled and cannot download all the IAPs on my iPad (PGC Extension Database; Interactive H-R Diagram; DAOA Extension Database) and iPhone (Interactive H-R Design)

  • 0
    Avatar
    Keiron Smith

    Hi Ted,

    Please tell me what app, version and IOS you are using.

    Please also try the following.

    1. Restore purchases.
    2. Let the IAPs restore (incompletely) as you have seen previously.
    3. When it looks like the restore process has stalled/ended, instead of pressing the Restore Purchases button again press the Done button instead.
    4. Return to SkySafari Settings page.
    5. Then check SkySafari In-App Purchases again.

    What happens?  Please attach screenshots.

    Thanks!

  • 0
    Avatar
    Ted Brauch

    SkySafari Pro; Ver 6.7.6.2 IOS 14.1 iPhone

    Done. Some progress but not sure

     

    This is what I see

  • 0
    Avatar
    Keiron Smith

    Great, that looks good to me.  

    Check if you can enable the H-R diagram - if you can then "Purchased" also means "Installed".

    Thanks, Ted!

  • 0
    Avatar
    Ted Brauch

    Thanks Keiron. that worked! Enable is turned on and now everything is working. 

  • 0
    Avatar
    Keiron Smith

    An excellent result, Ted!

  • 0
    Avatar
    Jose M Norton

    I've tried this, but I doesn't work on my iPhone.

    Any other suggestions?

  • 0
    Avatar
    Dave Whipps

    Hey all. Just wanted to mention that we've released a new version of the app, and that at least one user has confirmed that this issue is fixed.

    Thanks,

    Dave

Please sign in to leave a comment.