New post

How To Delete ALL SS6 Files From MacOS? (Answer: Read On!)

To Delete ALL SS6 files on MacOS find an delete the following files (in bold):

  • Mac HD/private/var/db/receipts/com.simulationcurriculum.SkySafari6MacPro.plist
  • Mac HD/private/var/db/receipts/
  • Mac HD/Users/user_name/Library/Saved Application State/com.simulationcurriculum.SkySafari6MacPro.savedState
  • Mac HD/Users/user_name/Library/Containers/com.simulationcurriculum.SkySafari6MacPro
  • Mac HD/Users/user_name/Library/Application Support/CrashReporter/SkySafari 6 Pro_AF9F6734-D903-5A67-8724-D3E210CD9706.plist
  • Mac HD/Users/user_name/Library/Application Scripts/com.simulationcurriculum.SkySafari6MacPro

Then try the app again.

These files and pathways were discovered using App Cleaner:

Simulation Curriculum does not endorse the use of App Cleaner.  Use at your own risk.



  • 0
    Nathan Murphy

    found all the same files, but this did not help a crash problem ... 13.2.1 2020 MBP M1.

  • 0
    Keiron Smith


    Have you tried reinstalling?


  • 0
    Nathan Murphy

    indeed - 5 or 6 times. I did the following, based on a related thread:

    1. delete all possible SS6pro files (manually and/or with App Cleaner)

    2. reboot

    3. reinstall SS6pro from App Store

    4. reboot

    5. launch SS6pro

    6. crashes after ~6sec. it starts, then there's a sort of spinning star at the bottom, then it crashes.

    this also started after I tried to import so older observing lists. I thought they might've been corrupted, so deleted them locally as well as LiveSky. that didn't help as I'm still crashing on install.

    I can add crash report here, or email if you'd like.

    I started my journey here: After Upgrading To MacOS Monterey 12.6 SkySafari 6 Pro Fails To Run (Answer: SS6 Pro Is Compatible With MacOS 12.6 - File Was Corrupted, Clean Install Fixed The Crash)

    but I have had no luck. there must be something corrupted that is not showing up in App Cleaner searches or manual searching.

  • 0
    Keiron Smith

    Yes, please add a crash report.

  • 0
    Nathan Murphy

    OK. here is the complete report:

    Translated Report (Full Report Below)
    Process:               SkySafari 6 Pro [977]
    Path:                  /Applications/SkySafari 6 6 Pro
    Identifier:            com.simulationcurriculum.SkySafari6MacPro
    Version:               6.8.2 (6820)
    App Item ID:           1362059613
    App External ID:       841646303
    Code Type:             X86-64 (Translated)
    Parent Process:        launchd [1]
    User ID:               501
    Date/Time:             2023-03-13 10:58:26.6637 -0600
    OS Version:            macOS 13.2.1 (22D68)
    Report Version:        12
    Anonymous UUID:        4E2192E8-A6E0-4CF1-9EFC-C1FC92BE5947
    Time Awake Since Boot: 81 seconds
    System Integrity Protection: enabled
    Crashed Thread:        0  Dispatch queue:
    Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
    Exception Codes:       0x0000000000000001, 0x0000000000000000
    Termination Reason:    Namespace SIGNAL, Code 11 Segmentation fault: 11
    Terminating Process:   exc handler [977]
    VM Region Info: 0 is not in any region.  Bytes before following region: 4309098496
          REGION TYPE                    START - END         [ VSIZE] PRT/MAX SHRMOD  REGION DETAIL
          __TEXT                      100d7a000-101116000    [ 3696K] r-x/r-x SM=COW  ...ySafari 6 Pro
    Kernel Triage:
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    VM - pmap_enter retried due to resource shortage
    Thread 0 Crashed::  Dispatch queue:
    0   SkySafari 6 Pro                     0x100f14ff8 0x100d7a000 + 1683448
    1   SkySafari 6 Pro                     0x100f13d3d 0x100d7a000 + 1678653
    2   SkySafari 6 Pro                     0x100da800b 0x100d7a000 + 188427
    3   SkySafari 6 Pro                     0x100da67ae 0x100d7a000 + 182190
    4   SkySafari 6 Pro                     0x100dda077 0x100d7a000 + 393335
    5   CoreFoundation                    0x7ff81769c2f7 __NSARRAY_IS_CALLING_OUT_TO_A_BLOCK__ + 7
    6   CoreFoundation                    0x7ff81769c17c -[__NSArrayM enumerateObjectsWithOptions:usingBlock:] + 224
    7   SkySafari 6 Pro                     0x100f6a8a7 0x100d7a000 + 2033831
    8   SkySafari 6 Pro                     0x100d8911d 0x100d7a000 + 61725
    9   SkySafari 6 Pro                     0x100e751ec 0x100d7a000 + 1028588
    10  SkySafari 6 Pro                     0x100e76225 0x100d7a000 + 1032741
    11  Parse                               0x10a696c75 __62-[BFTask(Private) thenCallBackOnMainThreadWithBoolValueAsync:]_block_invoke + 98
    12  Parse                               0x10a69698c __72-[BFTask(Private) continueWithMainThreadResultBlock:executeIfCancelled:]_block_invoke + 162
    13  Bolts                               0x10a481f28 __55-[BFTask continueWithExecutor:block:cancellationToken:]_block_invoke + 93
    14  libdispatch.dylib                0x7ff81744c7fb _dispatch_call_block_and_release + 12
    15  libdispatch.dylib                0x7ff81744da44 _dispatch_client_callout + 8
    16  libdispatch.dylib                0x7ff81745a7b9 _dispatch_main_queue_drain + 952
    17  libdispatch.dylib                0x7ff81745a3f3 _dispatch_main_queue_callback_4CF + 31
    18  CoreFoundation                    0x7ff8176e642d __CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE__ + 9
    19  CoreFoundation                    0x7ff8176a6ebb __CFRunLoopRun + 2498
    20  CoreFoundation                    0x7ff8176a5e7f CFRunLoopRunSpecific + 560
    Model: MacBookPro17,1, BootROM 8419.80.7, proc 8:4:4 processors, 16 GB, SMC 
    Graphics: Apple M1, Apple M1, Built-In
    Display: Color LCD, 2560 x 1600 Retina, Main, MirrorOff, Online
    Display: DELL U2711, 2560 x 1440 (QHD/WQHD - Wide Quad High Definition), MirrorOff, Online
    Memory Module: LPDDR4, Hynix
    AirPort: spairport_wireless_card_type_wifi (0x14E4, 0x4378), wl0: Nov 30 2022 03:35:43 version 18.20.379. FWID 01-9578a936
    Bluetooth: Version (null), 0 services, 0 devices, 0 incoming serial ports
    Network Service: Wi-Fi, AirPort, en0
    PCI Card: pci8086,15f0, USB eXtensible Host Controller, Thunderbolt@3,0,0
    USB Device: USB31Bus
    USB Device: USB31Bus
    USB Device: USB31Bus
    USB Device: 4-Port USB 3.0 Hub
    USB Device: USB3.0 Hub
    USB Device: USB3.0 Hub
    USB Device: Expansion
    USB Device: Expansion
    USB Device: Expansion
    USB Device: USB 10/100/1000 LAN
    USB Device: 4-Port USB 2.0 Hub
    USB Device: USB2.0 Hub
    USB Device: USB2.0 Hub
    USB Device: NAD USB Audio
    USB Device: USB Audio
    Thunderbolt Bus: MacBook Pro, Apple Inc.
    Thunderbolt Bus: MacBook Pro, Apple Inc.
    Thunderbolt Device: Thunderbolt 3 Dock Core, Belkin, 1, 50.1


  • 0
    Keiron Smith

    Ros Hartigan, this looks like an issue with LiveSky (Signal), is there something we can delete here that would help fix the crashing?


Please sign in to leave a comment.