New post

[Website] Invalid Certificate - Can No Longer Connect To LiveSky

I have an old iPad2 running iOS 9.6 and SkySafariPlus6. Been using it just fine at the telescope as my observing chart, using its observing sessions, lists, and observations. LiveSky has been working flawlessly for months keeping the data updated in the cloud and my other devices (iMac and iPhone) receive the observing info just fine.

Three days ago, I used the iPad to connect to one of my telescopes for the first time and it worked fine.

However, not I can no longer use LiveSky. I cannot connect SSP6 to LiveSky, I get an error message on the iPad that says:

The certificate for this server is invalid. You might be connecting to a server the is pretending to be "live" which could put your confidential information at risk.

So far, I have done these steps to no avail:

Tried logging out and into LiveSky

Deleted and installed SSPlus6

Reset Network Settings on iPad

Restarted iPad numerous times.

I can also reset the iPad completely, erasing all data and settings but I'd like to do that as last resort.

I'm guessing my iPad is simply too old, and perhaps something got changed when I connected it to the telescope.

I can get a new iPad, yes, but it was working fine until now.

Thank you



  • 0
    Keiron Smith

    Kyle Hendicks

  • 0
    Kyle Hendicks

    Hello Chris,

    This is definitely unusual. Let me research this a bit and see if I can figure out what is going on.

    Kyle Hendricks

    Simulation Curriculum Development Team

  • 0

    Hello, I have the exact same problem. I can login to livesky on my android device but not on the iPad 2.

  • 0

    Same issue

Please sign in to leave a comment.