New post

Connecting SkyFi-III to a USB to serial converter

I have a new SkyWatcher AZ-EQ5 mount and a SkyFi-III WiFi device and use SkySafari-6 Pro for mount control.

At first I was barely able to connect SkySafari to the mount using a USB A-to-B cable plugged between the SkyFi-III and the USB connector in the bottom of the HC.  I got successful connections only about 20% of the time.  SkyWatcher Support informed me that the USB cable can't be any longer than 6 ft. I was using an old 6 ft. USB cable.  So I switched to a better quality (larger wire gauge) 1.5 ft. USB cable.  My connection rate improved to 80%.  Much better, but not great.

After reading similar complaints, I tried a RS-232 serial cable (one from Amazon, one from Simulation Curriculum).  The pinouts are slightly different, but both work -- 100% of the time.  This is how it should be.  But I hate having two cables coming out of the bottom of the HC.  So when I discovered SkyWatcher's "SynScan USB Dongle" that can replace the HC (it plugs into the HC's RJ-45 socket on the mount head), I ordered one.

No go.  Nothing.  Refused to connect.  SkySafari said there was a wireless connection but the mount wasn't responding.  This dongle supposedly also can connect to the bottom of the HC.  So I tried that.  Again, nothing.

And then I completely removed the dongle and went back to the 1.5 ft. USB cable between the SkyFi-III and USB port on the bottom of the HC.  NOTHING!  It worked yesterday, but not now.

So I changed over to one of my trusty RS-232 serial cables plugged into the SkyFi-III and bottom of the HC.  It works -- and 100% of the time.

So, it's looking to me as if I've blown the mount's internal USB circuits.  Not good, but everything still works with a RS-232 serial cable.

Then I did some more research on this dongle and discovered that all it really is, is a USB to serial converter.  And the chip SkyWatcher put in the dongle is the notorious and infamous Prolific chip -- instead of the super stable FTDI chip that works all the time with everything.  And that to work, you need to load the latest and "proper" Prolific driver.

Well, since I'm running my system without any computer at all (so neither Windows OS nor Mac OS), there is/are no drivers.  And I'm guessing the SkyFi-III has no idea what it's connected to -- or how to make it work.  And neither is my Android phone.  So now I'm thinking that there's no way a SkyFi-III nor an Android phone running SkySafari can use this thing.  Is that correct?

And I'm wondering if the SkyFi-III actually blew up the USB circuitry in the mount.  I've noticed that if/when I turn mount power OFF and the SkyFi-III is still plugged into the HC -- the HC's screen remains lit.  So apparently the SkyFi-III is now powering the HC from its' own battery!  So there are some strange connections going on.

This is my very first SkyWatcher mount so I'm not at all familiar with it.  But I've had no similar problems with my Celestron, Takahashi, AP or iOptron mounts using this same SkyFi-III device.

Any guidance or tips or suggestions?


Please sign in to leave a comment.