New post
0

Browsers Supported by Simulation Curriculum Community Forums - Cookies Must Be Enabled

Browsers supported by Simulation Curriculum Community Forums.

The Simulation Curriculum Community Forums are tested with the browsers listed below. Older browsers can still be used, but newer features may not look or work as intended. We recommend that you always use the current version of a browser. Most browsers provide an option for automatic updates.

The following browsers are supported on desktop:

  • Google Chrome: latest two versions
  • Mozilla Firefox: latest two versions (see discussion below)
  • Apple Safari: latest two versions (see discussion below)
  • Microsoft Internet Explorer: latest version only
     
    Note: Microsoft Edge browser works in testing.  If anyone encounters difficulty with this Edge browser please comment below.

The following browsers are supported on mobile:

  • iOS 9
  • Chrome Mobile for Android: latest version

Browser configuration:

  • JavaScript must be enabled
  • Cookies must be enabled

7 comments

  • 0
    Avatar
    Display Name

    Testing on Microsoft Edge, and I don't find any problems.

  • 0
    Avatar
    Ed Hubble

    I've managed to log in. Finally!

    It required doing the hokey-pokey and turning to the left not the right! :-)

    My working hypothesis -- after much testing -- is that the setting for ALL cookies and not just sites I visit must be turned on! This is under iOS 10 with Safari.

    That's not a good setting, though, as gobs of tracking cookies get added when you surf the web!

    The other setting "Allow From Current Website" is much better and much preferred!

    I'll do some more testing and let you know if that really is it. If so, hope there's a way you can fix it in your end.

    In the meantime, it's late lunch time!

  • 0
    Avatar
    Keiron Smith

    Success, Ed!  Thanks so much for your persistence and troubleshooting!

    In your ticket you said: When I click on the message "Click here to enable them", the screen briefly refreshes on the iPad, but still does not let me sign in.

    - What sign-on service were/are you using?  I'm going to guess you were/are using the Simulation Curriculum Sign-On (Standard Zendesk)?  See below.

    Really nice breakthrough, Ed!

    I've done some additional testing given the information you have provided and this is what I find - and if you're feeling brave skip to: The solution (that will work)

     

    Safari Cookies Guide:

     

    About Apple Safari browser (Part 1):

    You will encounter difficulties using Apple Safari browser if you do not understand the following.

     

    The Error Message:

    Note the "Cookies must be enabled...Click here to enable them" message/link.  This is the error message we are trying to resolve.

    Social Media Single Sign-On:

    In my testing with Apple Safari browser, the Social Media Single Sign-On ALWAYS WORKS regardless of the whether the "Cookies must be enabled..." message is showing.

     

    Simulation Curriculum Sign-On (Standard Zendesk):

    In my testing with Apple Safari browser, if you try to login using the Simulation Curriculum Sign-On (Standard Zendesk) while the "Cookies must be enabled..." message is showing then the login attempt will fail.  

    Plus, if after trying to login using the Simulation Curriculum Sign-On you try to enable cookies by clicking the blue link then the login will fail again AND a new empty white browser window will open.  Note, the new browser window has the following title:

    The Solution (and if this does not work keep reading):

    If you are using the Simulation Curriculum Sign-On (Standard Zendesk) method then you must enable cookies BEFORE you attempt a login.

     

    About Apple Safari browser (Part 2):

    These are the Apple Safari cookie privacy options - we will be reviewing the two options in the red box:



    About the Apple Safari Privacy option - Allow From Current Website Only (this will not work):

    If you have selected this Apple Safari cookies privacy option, then when you click the blue link to enable cookies the screen will refresh and the error message will still be visible.  That is to say, you can NOT resolve the "Cookies must be enabled..." error message if this option is selected in your Safari browser privacy options.

     

    About the Apple Safari Privacy option - Allow From Websites i Visit (this will work, but read very carefully):

    If you have selected this Apple Safari cookies privacy option, then when you click the blue link to enable cookies the screen will refresh and the error message will disappear.  That is to say, you CAN resolve the "Cookies must be enabled..." error message if this option is selected in your Safari browser privacy options.

    However, this will only work if you have NOT first tried to login using the Simulation Curriculum Sign-On (Standard Zendesk) method.  If you have tried to login using the Simulation Curriculum Sign-On (Standard Zendesk) method then when you try to enable cookies by clicking the blue link then the login will fail again AND a new empty white browser window will open.

     

    The Solution (that will work):

    If you have selected the Apple Safari Privacy option - Allow from Websites I visit, and...

    If you have tried to login using the Simulation Curriculum Sign-On (Standard Zendesk) method, and, then...

    If you have tried to click the blue link to enable cookies, but have encountered the white screen, then...

    Click the browser REFRESH button, and then...

    Click the RELOAD button.

     


     

    Now, when the browser page refreshes the "Cookies must be enabled..." message will have disappeared, and you can login using the Simulation Curriculum Sign-On (Standard Zendesk) method.

     

    Talk about Mission Impossible!

     

    A super-huge thank you to Ed Hubble for shining a light on this issue!



  • 0
    Avatar
    Keiron Smith

    Updated, again, Apple Safari troubleshooting guide above.

  • 0
    Avatar
    Ed Hubble

    Appreciate your guide, Keiron!

    His advice applies equally to iOS-- i.e., iPad, iPhone, and iPod Touch.

    You need to go to Settings, Safari, and then, under Block Cookies (that's in the 3rd group of settings under the Privacy and Security), you want to choose "Allow from Websites I Visit".  

    Just remember to restore that to "Allow from Current Website Only" after you've signed in (or, "Always Block", if that's your preference).

    Now onto the boards and actual content about the apps and programs!

  • 0
    Avatar
    Jd 2 Astro

    Firefox Cookies Guide:

     

    I was having great difficulty getting Firefox to log into here. I use NoScript and had to allow several sites in addition to the primary one. But I was unable to get rid of the "allow cookies" message. I was not about to set Firefox to allow all cookies. I finally determined that I had to allow cookies for "https://simcur.zendesk.com". Then I was finally able to log in. You guys really made it tough.

    JohnD

  • 0
    Avatar
    Keiron Smith

    Thanks sooooo much, JohnD!  Apologies for the inconvenience.  I'm sure your reply will be very helpful for other Firefox users.

Please sign in to leave a comment.