New post
0

SkyFi III and Celestron Nexstar 8SE Connection Failure

I have a new Celestron 8SE, hand controller version; HC:NXS 5.31.9102 and MC:5.14 5.14.

After connecting my Ipad to the SkyFI 3 wifi. I went into settings in SkySafari Pro and selected my scope, Celestron Nexstar GPS/SL/SE. and mount type Alt-Az Go To. After I went and aligned my scope using the StarAlign method (3 bright stars) after confirmation I attached the SkyFi with a USB-A cable on the SkyFi to the bottom of the Nexstar Hand controller with a USB mini B connector. I then powered the SkyFi on. I then fired up SkySafari Pro and hit the connect button and received the following message... Connection Failure SkySafari Pro can make a wireless connection to the scope, but the scope is not responding. Make sure the scope is powered on an connection correctly. Also make sure you selected the correct scope type. 

Please advise what to do. Thanks

Loran

20 comments

  • 0
    Avatar
    Woody

    Loran,

    Your configuration is a little different than mine (I use StarSense instead of the NexStar for alignment), and I use Android devices instead of Apple.  But I might be able to help anyway.

    1)  You say you "connected" your iPad to the SkyFi-III.  So I assume that means you went through the setup procedure and entered the correct WiFi network and password and that your iPad really is "connected" to the SkyFi-III and not some other nearby WiFi network.

    2)  When you choose your mount in SkySafari Settings, did you also set it to Connect via WiFi, and not Bluetooth?  In order to use the SkyFi-III device, you must use WiFi.

    Hope that helps.  That's about all I can suggest, having no experience with iPads or the NexStar HC.

     

  • 0
    Avatar
    Lseeourpet

    Thanks for your help Woody,

    1)Correct,  I did connect my iPad to the WiFi of SkyFi-3.  No password was asked, but my iPad does show connected to SkyFi.

    2) When you asked about mount I assume you meant how it connects and not mount type. Under Setup /Communication Settings there is a tab called auto-detect SkiFi, I have that enabled. Other than that I don’ts see another tab to connect SkySafari by way of WiFi.

    Thanks again for your help especially on a Sunday!

     

  • 0
    Avatar
    Woody

    Loran,

    Sunday is no big deal for me.  I'm retired.  And I'm not an employee of Simulation Curriculum.

    No "tab" for Connect via Bluetooth.  It's the radio button just above Connect via WiFi.  But since you've already checked the Auto-Detect SkyFi box, you're in WiFi mode.

    And when you check that box, SkySafari looks for the default WiFi network name "SkyFi."  If you changed your SkyFi-III's network name (highly recommended), then I believe you also need to change the network name it needs to auto-detect.  So for example, if you changed your SkyFi-III's network name (SSID) to something like "Lorans_SkyFi", you also need to change the auto-detect name in SkySafari to the same network name -- "Lorans_SkyFi."

    I'm not sure because it's been years since I've done this.  I usually control my mounts via Bluetooth (iPads can't do that -- only Android devices) or using Celestron WiFi via a Celestron SkyPortal WiFi device on my CPC-1100 Deluxe mount, or the built-in Celestron WiFi in my Evolution mount.  But a couple of times I did connect to my SkyFi-III device, so I know it works.  And I do remember changing my SSID away from the default "SkyFi-III".  And to save time scrolling through available networks when I used it, I did check the Auto-Detect box -- and got everything working.

    I'm not home now, I'm in my RV.  But I think I brought my SkyFi-III along with the adapters and cables I need to test it with my Evolution mount.  I'll look for all that stuff tomorrow and if I have everything I need, I'll test it with my Evo mount and let you know how it works and what the setup is.  But it would be a good idea to check the instructions that came with the SkyFi-III to make sure you haven't changed something (such as the Network name).  And if you have, what you also need to change in SkySafari so it can find and connect to it.

  • 0
    Avatar
    Lseeourpet

  • 0
    Avatar
    Lseeourpet

    Woody, a night owl too I see by the time of response.

    I am retired too, to many hobbies keep me way to busy and up at night.

    I hadn't changed my SSID name but I could see it as a problem at a star party possibly. Anyways I did change the name to Lorans_SkyFi. At first it Auto-Detect showed, "Not Found" . I opened the setting information on the Ipad and saw it had the ip address as 10.0.0.2. I'm no computer geek but I knew that probably why it wasn't connecting. So I went into SkyFi wireless and changed the ip address to 10.0.2. and applied. Went back to SafariPro stil, "Not Found". Turned Ipad and SkyFi off. After turning everything back under  Auto-Detect SkyFi now showed 10.0.0.2 (which I assume now means it is connected) I will try in the morning ( when the sun is up) to try to connect to the scope again.

    Having said all that above I just went back into the information tab in the Wi-Fi settings on the Ipad for Lorans_SkyFi. and it shows Ip Address as 10.0.0.1 and the router as 10.0.0.2. Went back to SafariPro Telescope Setup and still looks like Auto-Detect SkyFi is ok.

    When you mentioned, "No "tab" for Connect via Bluetooth.  It's the radio button just above Connect via WiFi." I still can't seem to find it. Maybe it is an Android thing since you said Ipad's can't connect through Bluetooth and it is not in the software to see, maybe?

    Also there is a slider for Set Time and Location in the Telescope Set up of Safari, should I turn that on or let the scope do that.

    Anyways, thanks for all your help and safe travels back home.

    Loran

    Update Monday morning... still unable to connect to scope, sigh.

     

  • 0
    Avatar
    Keiron Smith

    Loran, 

    Connection Failure SkySafari Pro can make a wireless connection to the scope, but the scope is not responding. Make sure the scope is powered on an connection correctly. Also make sure you selected the correct scope type. 

    This error message means SkySafari and SkyFi 3 were talking to one another just fine.  The issue was with the scope, that it was not receiving/transmitting commands.

    You have the correct ScopeType selected.  So, I would point to one of the following:

    1. The USB cable from SkyFi 3 to hand controller was not repaying commands.  A different cable could be tried.  Not all USB cable relay data.  Some cables are made for charging only.  Or...
    2. The scope was not actually aligned.  Try a different alignment type, i.e. 2-star auto align.  The hand controller will say "Alignment Successful" so look for that too.

    To confirm that SkySafari is connected to SkyFi 3 there is an option "SkyFi Settings Webpage" (look in your last screenshot).  If you can open the SkyFi Settings webpage then you know that much is all good, and the issue is with the wire or the alignment.

    Thanks Woody!!

     

     

  • 0
    Avatar
    Lseeourpet

    Thanks Keiron,

    Will check on all your comments. I have searched for another cable but so far they all say charging cable.

    Loran

  • 0
    Avatar
    Woody

    Loran,

    1) Yes, that Bluetooth setting is only an option for Android,  So of course you wouldn't have it.  Duh!

    2) I like Keiron's suggestions.

    3) Not being an iPad guy, I didn't realize there are charge-only cables.  But yeah, that sure would be a problem.

    Now that Keiron is involved, I'm gonna take a back seat

  • 0
    Avatar
    Lseeourpet

    Thanks again Woody.

    Keiron,

    As instructed  I opened SkySafari and went to the option "SkyFi Settings Webpage" (look in your last screenshot). " If you can open the SkyFi Settings webpage then you know that much is all good." Nothing appeared so I did the reset on the SkyFi. Repeated the process and was able to see the SkiFi Settings Webpage. Still no connection, received the same message, "Connection Failure SkySafari Pro can make a wireless connection to the scope, but the scope is not responding......"

    I than did the Auto 2 star align and received the message, align successful, still received same message, "Connection Failure....."

    I went to the local electronic store and bought another USB A to USB B Mini and still no connection. They only had one cable so I went on to Amazon and have 3 different manufactures cables coming in the next few days. 

     

  • 0
    Avatar
    Woody

    I wonder if this could be a Celestron firmware issue?  By that I mean the firmware in the mount and NexStar HC being so old SkySafari doesn't recognize it?

    Is that possible Keiron?  In the past we've had serious problems with old Celestron StarSense firmware not matching and working with the latest SkySafari software.  But as soon as the Celestron mount and HC firmware was updated, things worked again.  I realize Loran is using the regular NexStar HC and not StarSense, but could out-of-date Celestron firmware be the problem?

  • 0
    Avatar
    Lseeourpet

    Well its a recently purchased scope. The newest hand controller version is NXS 5.31.9200 (August 2019) mine is NXS 5.31.9102, which came out around May 2019 ( and the Motor controller version is the same MC:5.14.

    Before I update the firmware on the hand controller I am going to wait for the new cables. At least the scope works now. Don't want 2 problems :). 

    Also I noticed that when I went back to try to connect again that the SkyFi Web Page didn't load. I had to turn SkyFi off a few times as well as close and reopen SkySafari to have them connect again.

  • 0
    Avatar
    Keiron Smith

    Firmware should be fine as the hand controller has the latest USB-mini port, so must be shipping with recent firmware updates.

    Let's see what happens with the new USB cables.

  • 0
    Avatar
    Lseeourpet

    I received the couple of cables today. Following the instructions again on how to connect by using an Auto 2 star alignment, turning on SkyFi and making sure my Ipad was connected to it and that SkySafaria was connected to SkyFi (using auto connect in SkyFi settings) and verifying it was connected by viewing the SkyFi Settings Web Page (even though under Auto-Detect SkyFi confirmed it was connected to 10.0.0.1) I hit the connect tab. Holy cow I was controlling my scope with my Ipad. HOWEVER, after a couple of GoTo's I received a message that it had disconnected ( cant remember the actual wording) . Went back to settings and under Auto-Detect SkiFi was, Not Found. I tried to reconnect but after more than a dozen attempts I gave up. In those more than a dozen attempts I had shut down everything (except the scope) and back on again to no avail. Very frustrating to say the least.

  • 0
    Avatar
    Lseeourpet

    Hello again,

    I appreciate your help in this matter. I was hoping to get an additional direction before the weekend. I know with the current situation of office help is scarce in these Covid times. Thanks again for any help. 

  • 0
    Avatar
    Keiron Smith

    A dozen attempts and receiving what error message?  Please attach a screenshot of error message.

    And confirm the battery is charged.

    Thanks!

  • 0
    Avatar
    Lseeourpet

    Not really an error message rather on setup page under Auto Detect SkyFi "not found' . I tried turning off Auto-Detect SkyFi too and have it connect with10.0.0.1 and it wouldn't. The only time I was able to run the scope with the software was with Auto-Detect Sky-Fi and under it showed the ip address as 10.0.0.1 The battery on SkyFi showed 90 percent charged at the time I was able to run the scope with the software.

  • 0
    Avatar
    Keiron Smith

    Reboot device and try again,

    Please see if you can connect to the SkyFi 3 via other device, computers, etc.

    Also, reset the SkyFi 3 unit and try again.

    https://www.skysafariastronomy.com/skyfi_3_quickstart_guide.pdf

    Thanks!

     

  • 0
    Avatar
    Lseeourpet

    Will do tonight,. thanks

  • 0
    Avatar
    Lseeourpet

    Followed your above instructions. Connected to an Ipad Pro and an Ipad (8th generation). Made sure SkyFi was fully charged.

    Was only able to connect one time, (in about 8 tries), again only for a couple of minutes before I got the message, Connection Failure...

    I also acquired 2 more cables which didn't seem to work.

    Attached are screen shots.

     

  • 0
    Avatar
    Keiron Smith

    The error messages suggest the issue is with the telescope, i.e. "...the scope is not responding..." and not the SkyFi.

    Please try again with Set Time and Location option turned ON.

    Also, confirm that the scope is working fine without the SkySafari and SkyFi 3, i.e. align and use the scope via the hand controller only.

    Thanks!

Please sign in to leave a comment.